Algunas informaciones publicadas con anterioridad indicaban la intención de la compañía de reforzar la seguridad del servicio contra los ataques de phishing. Las primeras informaciones indicaban incorrectamente que Safari podría verse afectado por dicha medida.

Michael Oldenburg, portavoz corporativo de PayPal, ha declarado a 9 to 5 Mac: "PayPal está desarrollando características para bloquear la conexión al servicio de los usuarios cuando utilicen un navegador antiguo o sistemas operativos no soportados. Un ejemplo de dicha combinación de navegador/sistema operativo podría ser, por ejemplo, Internet Explorer 4 funcionando sobre Windows 98. Al hacerlo podemos proteger en mejor medida a nuestros usuarios frente a la posibilidad de que accedan a un sitio malicioso mediante su navegador. No tenemos ninguna intención en absoluto de bloquear a las actuales versiones de cualquier navegador, incluido Safari".