Investigadores europeos han descubierto que el 99,7% del os dispositivos Android disponibles en el mercado presentan una vulnerabilidad, que deja expuestos a los dispositivos que se conectan a redes Wi-Fi abiertas donde puede accederse a los “authTokens” de Google.

No obstante, el problema puede evitarse en las versiones Android posteriores a la 2.3.3 y la versión 2.3.4 incluye un parche que lo resuelve. Es explotable mediante un ataque de suplantación de los servicios de Google.

Cuando los usuarios se acreditan en los servicios de Google desde una aplicación Android se descarga sobre el dispositivo un elemento (authToken) que sirve al sistema para “recordar” a cada usuario.

Tales authTokens son válidas durante un período de dos semanas, durante las cuales puede interceptarlas si son enviadas a Google sobre redes sin cifrar.