Apple ha arreglado algunas vulnerabilidades críticas detectadas en la última versión de su reproductor QuickTime. La actualización 7.2 del producto permite ver vídeos a pantalla completa, pero el software también contiene un buen número de fallos de seguridad. En total, Apple ha detectado ocho vulnerabilidades.

Cuatro de las vulnerabilidades se deben a corrupción de memoria o desbordamiento de buffer, y podrían provocar cuelgues si se utiliza QuickTime para ver películas o archivos manipulados. Otras tres vulnerabilidades críticas afectan a QuickTime para Java. En teoría, los atacantes podrían explotar estas vulnerabilidades publicando applets de Java maliciosos en un sitio web, desde donde podrían dañar el ordenador de la víctima. Otro de los fallos de seguridad detectados podría abrir una puerta a los hackers para obtener información privada del usuario, según Apple.

El miércoles, Apple anunció una nueva versión de iTunes que parchea un problema menor de la versión 7.3 al acceder a la librería, según la compañía. Tanto QuickTime como iTunes están disponibles para la , en versiones para usuarios de Windows y Mac OS X.