Aunque Excel incluye una batería de más de trescientas funciones, pocas veces las usamos. La función condicional ‘SI’ permite resolver situaciones muy comunes. Y es aún más poderosa combinada con otras funciones.

La hoja de la Figura 1 es una lista de vendedores con el importe de sus ventas. Queremos dar un premio de 50 € a quienes hayan superado la meta de 5.000 € vendidos.

Considerando los importes de las ventas en la columna C, a partir de la segunda fila (reservamos la primera para títulos) el premio se obtiene escribiendo en D2 la función condicional =SI(C2>5000;50;0).

La función condicional SI tiene tres argumentos entre los paréntesis:

  • El primero es la condición de la que depende el valor que finalmente devolverá la fórmula. En nuestro caso, que las ventas superen la meta de 5.000 €.
  • El segundo es el valor que devolverá la fórmula si la condición se cumple. En nuestro caso, el premio de 50 €.
  • El tercero es el valor que devolverá la fórmula si la condición no se cumple. En nuestro caso, cero, porque para ellos no hay premio.

La función escrita en D2 debe extenderse luego a toda la lista.

funciones condicionales en excel

Suma con condiciones. La función SUMAR.SI

La función SI no es la única función condicional de Excel. Por ejemplo, la hoja de la Figura 1 indica, en la columna B, la región a la que pertenece cada vendedor. Queremos calcular el total de ventas de la región Sur. Para esto podemos usar la función SUMAR.SI: =SUMAR.SI(B2:B11; “Sur”;C2:C11), tal como se ve en la hoja de la Figura 2. Esta función también tiene tres argumentos entre los paréntesis:

  • El primero es el rango donde se evalúa la condición. En este caso, el rango donde se indican las regiones.
  • El segundo es el valor que debe tener el rango anterior para que sea tenido en cuenta en la suma. En este caso, la palabra Sur.
  • El tercero es el rango que se suma. En este caso, el de las ventas.

La función SUMAR.SI compara cada celda del rango indicado como primer argumento con el valor del segundo. Cuando se satisface la igualdad, suma el valor correspondiente del tercer argumento.

Condicionales combinadas

El cálculo anterior puede hacerse también con una variante poco conocida de la función condicional, combinándola con la sumatoria: =SUMA(SI(B2:B11= “Sur”;C2:C11)). Pero, atención, a esta expresión hay que darle entrada con la combinación de teclas Control + Mayús + Intro.

Como se ve en la Figura 3, la fórmula queda encerrada entre llaves. Estas llaves no se escriben, sino que aparecen como consecuencia de haber usado la combinación de teclas Control + Mayús + Intro.

En esta expresión se evalúa la condición de tener el valor Sur en el rango B2:B11. Si se satisface la condición, se suma el respectivo valor de C2:C11. El resultado es el mismo que el devuelto por la función SUMAR.SI.

Cálculos con más de una condición

La fórmula del ejemplo anterior admite variantes más complejas. Por ejemplo, en la hoja de la Figura 4 combinamos la suma y la condicional para sumar las ventas de la región Sur, que superan los 3.000 €: =SUMA(SI(B2:B11=”Sur”;SI(C2:C11 >3000;C2:C11))). A esta expresión también se le da entrada con la combinación de teclas Control + Mayús + Intro.

Esta fórmula evalúa primero la condición de pertenecer a la región Sur. Si esta condición se cumple, evalúa si las ventas son mayores que 3.000. Si esta segunda condición también se cumple, se suma el correspondiente valor de ventas.

Conteo condicional

En principio, cualquier función estadística o matemática puede sujetarse a una condición. Por ejemplo, la hoja de la Figura 5 muestra una lista de alumnos con la calificación obtenida en la columna C. ¿Cuántos alumnos del turno Tarde obtuvieron una nota mayor que 5? En este caso tenemos que vincular las funciones SI y CONTAR: =CONTAR(SI(B2:B11=”Tarde”;SI(C2:C11>5;C2:C11))).

Como en las casos anteriores, a esta expresión se le debe dar entrada con la combinación Control + Mayús + Intro.

La expresión evalúa las condiciones de pertenecer al turno Tarde y tener una nota mayor que 5. Si ambas condiciones se cumplen, se cuentan las notas.

funciones condicionales en excel

Máximo condicional

Ahora supongamos el caso de una hoja de dos columnas: en la primera tenemos fechas y en la segunda tenemos los nombres de personas que visitamos en cada fecha. Una persona puede repetirse porque la visitamos más de una vez. Queremos saber cuándo fue la última vez visitamos a Pedro.

Este problema equivale a encontrar la mayor fecha (es decir, la última) para la cual en la segunda columna está el valor Pedro: =MAX(SI(B2:B11=”Pedro”;A2:A11)).

Esta fórmula se interpreta de forma similar a las anteriores: se evalúa si en el rango B2:B11 está el valor Pedro. De las filas que cumplen esta condición, busca la que tiene el máximo valor en la columna de fechas.

Se pueden hacer cálculos similares combinando la función SI con MIN, PROMEDIO, MODA, etc; siempre oprimiendo la combinación Control + Mayús + Intro para dar por ingresada la fórmula.

funciones condicionales en excel

Claudio Horacio Sánchez es ingeniero industrial y profesor de física y de informática en la Universidad de Flores (Argentina). Ha escrito varios libros sobre Excel.

Otros artículos sobre Excel: